AstroStar 14.0, 13.0 und 12.0: Fehler beim Laden oder Eingeben eines Horoskops nach Windows Update (GELÖST: Stand 9.3.2019 final)

Problem

AstroStar 14.0 sowie AstroStar 13.0 und 12.0 auf Windows 7 oder 10 beenden sich ohne erkennbaren Grund ohne weitere Fehlermeldung beim Laden eines Horoskops aus dem Archiv oder beim Eingeben eines Horoskops nachdem der Ort eingegeben bzw. ausgewählt wurde. Das Laden mitgelieferter Horoskope aus dem Archiv (z.B. "Enrico Caruso") ist jedoch ohne Problem möglich.

Ebenso ist die Funktion "Import älterer Datenbanken in AstroStar Profi 7.0 und 8.0" derzeit nicht möglich.

 

Generell nicht betroffen sind AstroStar Profi 5.0, 5.1, 6.0, 7.0 und 8.0 sowie unsere aktuelle AstroStar 14.0 Downloadversion (nach dem 22.2.2019).

Für die AstroStar 14.0 BOX Version und für ältere AstroStar 14.0 Downloadversionen (vor dem 22.2.2019 oder von Händlern, die unter Umständen noch nicht auf aktuellem Stand sind), gibt es eine Datenbankaktualisierung, welche das Problem behebt (siehe weiter unten).

Für AstroStar 13.0 und 12.0 gibt es keine Abhilfe über eine Aktualisierung, aber andere Lösungsmöglichkeiten, siehe weiter unten.

 

Ursache

Das Problem wird in VB6 Programmen, die mit Micorosft Databases arbeiten, u.a. durch ein seit Januar 2019 nach und nach veröffentlichtes fehlerhaftes Microsoft Update  für Windows 7 und 10.

Ausführliche Informationen hierzu liefert beispielsweise dieser Arikel von heise online:
Hier klicken: zum Artikel (externer Link, Sie verlassen unsere Internetseite)

 

Abhilfe

AstroStar 14.0 (Download- und BOX Version mit CD)

 Möglichkeit 1

Mit Hilfe einer speziell für dieses Problem erstellten Aktualisierung für Astrostar 14.0 wird das Problem behoben.

Bitte beachten Sie: Durch diese Aktualisierung für AstroStar 14.0 wird die Horoskopdatenbank von AstroStar 14.0 auf ein anderes Format umgestellt. Hierbei gehen alle in der Horoskopdatenbank enthaltenen Daten verloren. Mit Hilfe der in AstroStar 14.0 integrierten Funktion zum Daten sichern/wieder herstellen können Sie Ihre Horoskopdaten jedoch erhalten.

Aktualisierungsprogramm herunterladen:

Hier klicken: AstroStar 14.0 Aktualisierung Horoskopdatenbank

Sie erhalten eine E-Mail mit dem Download Link zum Herunterladen des Aktualisierungsprogramms und einer ausführlichen Anleitung zur Durchführung auch der Datensicherung/ Wiederherstellung.

 

Möglichkeit 2 (nur Download Version)

Sollte Möglichkeit 1 nicht funktioniern, können Sie auch wie folgt vorgehen:
Laden Sie das Instalationsprogramm für AstroStar 14.0 neu herunter und installieren Sie damit AstroStar 14.0 neu. Im aktuellen Installationsprogramm für AstroStar 14.0 ist bereits die Horoskopdatenbank in dem geänderten Format enthalten, sodass der durch das Windows Update verursachte Fehler nicht mehr auftritt.

 

AstroStar 13.0, 12.0, Profi 4.0 (Downloadversionen und BOX Versionen/CD)

Für AstroStar 13.0 und ältere AstroStar Programme kann das Problem leider nicht durch ein Update behoben werden, da diese Programme auf einem technisch älteren Stand sind, von dem aus eine Lösung nicht möglich ist.

 Möglichkeit 1

Wechsel auf das aktuelle Einsteiger Programm AstroStar 14.0 oder auf das aktuelle Profi Programm AstroStar Profi 8.0 um, da hier das beschriebene Problem nicht mehr bzw. nicht auftritt. Hier klicken zum AstroGlobe Online Shop

 

Möglichkeit 2

Soweit bisher bekannt ist, tritt das Problem offenbar nur auf Windows 7 und Windows 10 auf. Sofern Sie noch einen Computer mit Windows XP, Vista oder Windows 8/8.1 haben, können Sie AstroStar 13.0, 12.0 oder Profi 4.0 hilfsweise auf diesem installieren, und schauen, ob das betroffene AstroStar Programm darauf funktioniert.

 

Ausblick:

Microsoft hat Quellen zufolge die Lösung des Problems über ein korrigiertes Windows Update wohl hoch priorisiert. Man kann daher durchaus annehmen, dass das Problem mit einem der nächsten Windows Updates behoben werden wird, und AstroStar 13.0 und älter dann wieder wie zuvor funktionieren. Allerdings gibt es ein solches Update unserer Kenntnis nach bisher noch nicht  (Stand 9.3.2019), auch haben wir leider keine Kenntnis darüber, ob und wann es ein solches Update tatsächlich geben wird.

 

 

 

Haben Sie Fragen? Anfrage einreichen

0 Kommentare

Zu diesem Beitrag können keine Kommentare hinterlassen werden.